How do I change the URL for accessing Baserow?

I installed baserow, and the current access address is: http//:10.x.x.x:80, but now I want to access baserow through http//:10.x.x.x:80/mybaserow, what should I do?

I have tried adding “homepage” in pakage.json, and also tried configuring location in nginx, but both failed

I don’t think that you can do that, given that our frontend router will always override the url to not include your prefix.

1 Like

See Allow running Baserow under an URL prefix (#1179) · Issues · Bram Wiepjes / baserow · GitLab for where we are tracking support for adding Baserow under a domain path prefix. For now you will have to run Baserow on it’s own domain if you want a separate URL for it.

1 Like

Hi nigel,I just saw your reply,In the same way as you provided, I solved the access and login problems by modifying the configuration file of, and solved the connection problem of ws through the configuration of nginx.

But I try to use to access baserow, just like the ISSUE: , my media files and images in /static/img cannot be accessed, the error code is 404, I am trying to modify the environment variables PUBLIC_WEB_FRONTEND_URL and MEDIA_URL to solve it, but it seems to have no effect :neutral_face:

Thank you for your reply. I can now access and log in to Baserow through http://10.x.x.x:80/mybaserow by modifying the configuration file of nuxt.

Of course, this is only a temporary modification of my own, just to test whether I can modify the URL to access baserow

1 Like

To clarify for future readers how did you configure your other Baserow environment variables?

In this situation if I was you I would set:

and not set or change any of the other URL variables like PUBLIC_WEB_FRONTEND_URL or MEDIA_URL

I set the environment variable as follows:
docker run -e PUBLIC_WEB_FRONTEND_URL=http://10.x.x.x:80:3000/mybaserow \

In fact, setting the environment variable is effective. The PUBLIC_WEB_FRONTEND_URL I set was wrong before, and now the Baserow can be used normally :slight_smile: