How to search rows with one or more conditions using

Hello Baserow Community,

I hope this message finds you all well!

I’ve been enthusiastically working to integrate Baserow into my workflow. Despite my efforts and time invested in navigating through the documentation and community tickets, I’ve encountered some challenges that have hindered my progress.

I am committed to making this transition work, but I’ve reached a point where I could really use your expert guidance to move forward efficiently.

My primary challenge revolves around building scenarios using in conjunction with Baserow. Specifically, I’m struggling to utilize the ‘List Rows’ module effectively. Despite following the available documentation, I seem to be missing something crucial, as my search queries don’t return any results.

As recommended in tickets here, I also try the Make an API call and the HTTP modules, with no luck.

Could anyone provide insights or examples on how to correctly configure the ‘List Rows’ module to search records with specific conditions? Here are some examples of what I need to achieve:

Any guidance, would be tremendously helpful.

Thank you so much for taking the time to read my request. I am eager to learn from this wonderful community and look forward to your advice!


The default Baserow blocks in Make are indeed a bit basic when it comes to filtering records. My suggestion is to use the Make an API call block.

In your Baserow dashboard, you can click on the 3 dots next to the database and select View API docs. This will offer you a lot of information about what you need to enter in the building block.

For example: the List rows section of each table shows you to url where you need to make the call to:

If you scroll down a little further, you can create your own filter. This allows you to create the filter just like you would do in Baserow

Next, you copy the Query parameter to the clipboard and paste it into the Make block.

Thank you @frederikdc I will try this as soon as I have to build a new solution that requires database and integration.

Hi @frederikdc, I hope you are doing well.
I just tried your suggestions.

In both cases I got the same error


This is where I am reading the Value parameter


Thank you again for your help.


The url should be relative, so starting with /api/database/... instead of Maybe this solves the problem?

I change it but keep having the same error.

Thank you!

Hi Cecizu. I was having a similar battle. It might be helpful to read the thread about it here. :slight_smile:

1 Like