Airtable import "process is running"


I started an import Airtable task. It was taking long time so i closed it and tried to start again. Now it shows notification that there is already a process running .

I deleted the database and workspace and created another one but it gave same error. I stopped server and restarted but same error.

Is import process running through a third party server?

Hello @verifybudi, the Airtable import is still in the Beta stage and the functionality is less stable, sometimes importing doesn’t work properly.

@bram can you please check out this request?

Hi @verifybudi, I’m sorry to hear that the Airtable import is not working for you. If I understand correctly, then you’re using the self-hosted version of Baserow. The import process does not run via a third-party server, everything runs on yours.

Would you mind sharing some more details of your self-hosted setup? Does the progress of the Airtable importer start, or is it stuck on 0%? If sounds like asynchronous jobs are not being picked up. What happens if you try to export the data of your table, I’m curious if that works?

It was stuck at 0% for a long time.

It could not be cancelled despite clicking cancel button.

It doesn’t seem like the Airtable import job is being picked up by the async worker. Would you mind sharing more information on how you’re currently self-hosting? Can you also confirm that the export data job doesn’t work as well? You can try this by clicking on the three dots next to a table or view, and then click on export.

The import works for air table usually. i used it before. Reason i put the post was if it is stuck at 0% then then it cannot be cancelled.

I had to tried deleting base, then tried deleting container then deleted container then had to delete whole image in Docker (windows 10).

Now i don’t have a log for it as i reinstalled all.

If error found in importing airtable or times out then process should give message and self-terminate itself. That is why expected.