Anyone having issues with data operations and display on Firefox?

We have about 30 tables and 3000 rows on self-hosted Baserow. I noticed the following issues while using it on Firefox:

  • In the table view, selecting the date is sometimes not working, either month change or anything. No error in the console log/network tab
  • When using the row details view (modal form) and changing values that would hide this row with selected filters in the table view - sometimes it hides it (shows yellow border and notification), sometimes it doesn’t and I need to refresh

Are these things happening on Chrome-based browsers too? It looks like purely frontend app issues.

I’m using Firefox with Baserow and I haven’t noticed these issues but may be I don’t have the same usage. Good catch, it’s clearly more frontend related bugs :slight_smile:

When these bugs happen do you have the possibility to post a small video showing them? May be it comes from a specific field type or something like that?

Hey @jrmi I actually got one a moment ago, see here:

Thank you very much for the video it helps a lot.

It happens randomly? What is the frequence? Is it with some specific tables or it could happen with any table? Is it only when you use the search feature?

Hey,

Is it only when you use the search feature?

No, I just filtered for clear view.

It happens randomly? What is the frequence? Is it with some specific tables or it could happen with any table?

yes, it happens randomly, or at least I was not able to reproduce it on demand…

I just checked and it seems it’s not happening on the linked table, so the issue happens on this specific table. It affects all rows on this table. Logout and login didn’t help.

Interestingly, I logged in using Firefox Private window and seems to be working. On Chrome also works.

I logged back in normal mode and the issue is there. Must be something with browser cache, session storage, cookies etc?

interesting indeed…

Could be, but I don’t think we play with cookie or storage for these features. Could you try to nuke all your browser storage to see if it’s related or if it’s a side effect of private browsing somehow?

This could possibly also be caused by a firefox extension and that extension is not being loaded when you use an incognito window, which is why it works under those circumstances. Try disabling each extension manually and testing to see if the functionality works without each extension.

1 Like

I removed all cookie data, got logged out, logged in and works fine. So something with cookies…

@cwinhall Good point. Next time it happens I will try and report.

@cwinhall The issue appeared again. I disabled all plugins, and refreshed the page and still the same.

I am wondering if this would have something to do with my server setup. I run BR together with other services like N8N on a single VPS. The way how it’s done is:

I remember I had issues with sockets with N8N, not sure if this is the matter here. I am wondering how I could try and replicate this issue on another setup, maybe using baserow.io plan?