Baserow API connector to Bravo Studio

I put a self hosted baserow container on docker on my synology NAS. All works perfectly.

I want to use a database with Bravo Studio, I need to make an API connector from Bravo Studio to my database.
And i don’t find how to make it.
Any help possible ?

1 Like


Nice to see that you combine Baserow with Bravo Studio. I took the following steps to set up a connection in Bravo Studio. Note that I use the cloud version of Baserow, but I think that in the self-hosted version you only need te change in your own url.

  1. Click API collections in Bravo Studio and Select “Create a new collection”
  2. Pick the option “Start from Scratch” and offer it a name and description (I always pick the name of my base of the name for the collection)
  3. Make a request to the Baserow API like in the screenshot below. Notice that you need to offer a header with the name “Authorization” and a value "Token " followed by the token of your base.

You can use the send button to test if data is returned.

To get more information about the API (endpoints, expected responses,…), you go to your baserow instance, click the 3 vertical dots next to your instance and select “View API docs”



Thanks for your help, but it does not work.

I have an error message when i click on “send”

I take the token ID i create on baserow here :

Dit you put the word “Token” in front of the actual token? For example: if the token itself is 34xkr235wa, you need to enter “Token 34xkr235wa” as the value of the Authorization.

If this was not the problem, I would suggest that you use a tool like Postman to check if you can make calls to the API.

Wow. Thanks for your help. It works now.

I check with the API documentation, and i don’t see that I need to put the word "Token " somewhere…

Now I see on your capture you make an API request for every column in the table. So I think I need to do same to after make the connector with bravo studio.

Indeed, you need to set up a new request for every interaction with the database.

Thanks for helping.
Now go to bravo studio and try to link all those things together

Hi frederikdc,

Do you use baserow ?

Here for the authentication do i need to put something ?
When i try to use the app in bravo vision, the date don’t populate the zone in the app, i get a 401 error authentication.

You do not need to put anything in the settings of your collection as long as you pass the token in the header of your request

If you click the Send button, you can check if the connection works or not.

Yes when i click on send it works.
But when i’m on bravo vision with the app, i get a 401 error authentication failure.

Just tested it for myself. It has been a while since the last time I have used Bravo, so I needed to update the Bravo Vision app and I got the same error message.

The solution is in updating the setting of your API collection to the following:

where the value contains your token with the word “Token” in front of it. You can now remove the header information for each request.

If I run this in Bravo Vision, the application works fine.