Baserow error 400: Zapier returned "The provided select option value '392141' is not a valid select option."

Describe the problem

I tried to create a zap where a new row in Baserow is created. The zap works fine until I try to use it to pre-fill info in a single choice column in Baserow. Zapier correctly shows the options that are already in there, but whenever I actually choose one, the test of the zap gives a 400 error with “The app returned “The provided select option value ‘392141’ is not a valid select option.”

Describe, step by step, how to reproduce the error or problem you are encountering.

  1. Create a table in Baserow with a single select column
  2. Create a Zap that includes a step that creates a new row in baserow
  3. Try to prefill the single select column with one of the displayed single select options
  4. Run a test

Provide screenshots or include share links showing:

<!--- ![image|329x500](upload://bt2kX7RKDLBr0aONavYcfO89XEB.png) ![image|413x500](upload://r8GIHZb7wX0tzeql9HAkflXl29c.png)

Hi Sarah,

I tried to simulate your problem and got the same error (which is good news actually).

I “solved” it by skipping the test first so that it is ready to publish the zap. But instead of publishing the step, I selected the option to Retest the step which strangely results in a successful execution


1 Like

Thanks for your reply Frederik!

Unfortunately this workaround seems not to work on my end. Have you tried to publish the Zap? If so: Is it working when actually triggering the automation (hence it might just be a displaying issue in the test mode)?


I have published it now with a trigger that runs it every hour. It just has executed with success.

1 Like

Sorry for my late reply and thanks for all your effort frederik! I can confirm from my side that the published zap works as intended so it just seems to be a displaying error of some kind.