Baserow fail on Digital Ocean Self-host Setup

Hey all, I have followed the Baserow perfectly twice and I am still having issues.

I am trying to install Baserow on Digital Ocean.

The first install the build step kept failing.

Yesterday I tried again and the logs kept saying they could not connect to the DBs.

I checked every step multiples times and even tried changing a handful of settings to see if that helped.

Nothing seemed to work.

If is possible there is a step missing in the process? Maybe some updates to Digital Ocean are changing the way things need to be setup?

The one thing I plan to try next is to use the latest version of PostgresSQL v16 instead of v15 and see if that makes any difference.

Any guidance would be helpful.


It’s a bit hard to give you a specific answer without technical details. Could you show exact error message (preferrably with full traceback) you’re getting?



Hey Cezary, appreciate the reply.

So I followed the instructions exactly provided by Baserow and both time it failed.

The first time the build step would not complete for the app.

From what I could see in the logs Baserow failed to initialize.

The second time the build step would complete but the hosted URL showed nothing and the logs said the app could not connect to the DB.

I thought maybe the instructions are outdated or something.

I ended up doing the one click template build on Railway for just to get something up and running to test on.

My mail goal with self hosting was to get around row limits.

Otherwise I would be happy to pay for the hosted version.


Could you show exact error messages related to those issues?