Can't export tables


I am getting an error when trying to export my tables, but not much info on how to solve it. Is there any place where I can see further logs or some other information?
This is the error I am getting on the frontend

Any tips on how to solve this issue will be appreciated!

Is it still happening? It is working for me. Are you using the Baserow hosted version, selfhosting or somewhere else?

Hi @yakito, I’m also curious whether you’re using the hosted or self hosted version. I’ve not seen any errors related to exporting for the hosted version. If you’re using the hosted version, would you mind sharing your table ID by posting the entire URL of the page when looking at the table.

1 Like

Hi! thanks for the fast reply! I am using the self hosted version with Heroku via the 1-click install.
Is there any other information I can provide?

Hello guys! Any ideas or suggestions on how to fix the error? Or where to look to troubleshoot it?
Thanks a lot!

Maybe you can tell something about the structure of the table you want to export? It’s structure/fieldtypes, etc.

Thank you @Peter
Right now anything I try to export will fail, something as simple as this

Thats why I was thinking there might be a log somewhere with some error with more details maybe?

I tried exporting views and entire tables, and always the same error so far

any suggestion will be appreciated!

So it could be something Heroku related.

I tried to install on Heroku so i could test it but it is asking for credit card data so didn’t go any further.

1 Like

Thanks a lot Peter, I will try to do the inverse, install Baserow in an Ubuntu server outside Heroku. TBH, I want to move into Baserow cloud solution… but I need to take my data with me.

Hey @yakito ,

Apologizes for the delay, I’ve attached a gif showing to to get at the logs for our heroku env:

In written steps could you:

  1. Open your Baserow Heroku App
  2. Click the More button in the top right
  3. Click view Logs
  4. Now go and do a baserow export in a separate tab
  5. Finally private message me the logs, you should see some indication that an export job ran and failed in them hopefully.

I just checked with a clean install on Heroku and everything works me me. Exporting depends on persistent file storage to temporarily store the export. Could it be that you’ve added some S3 related settings that might be incorrect? What happens for example when you try to upload a file into a file field, do you then also get an error?

I’ve been able to reproduce your situation by adding an invalid AWS_ACCESS_KEY_ID to the settings, which makes Baserow to try to store persistent files in an S3 bucket. If you haven’t added a S3 related settings, I would also love to see the error log as @nigel described.

1 Like

Thank you @bram and @nigel I am sending you the logs right now.

I haven’t added S3 related settings, so I don’t think that seems the be the cause.

For what I find out from the logs, it looks like Baserow is returning a 500 error when trying to export the table which is strange because the API call to that same URL returns the correct data.

Anyway I will send you the logs and maybe you see something I don’t.
Thanks A LOT for all your help!

Would you also mind sharing a screenshot of your Heroku config vars? Please blur everything that contains privacy sensitive information. You can find that under your settings.

1 Like

I don’t see anything strange. Have you tried restarting your Dyno before? Which version of Baserow are you running?

1 Like