Can't read /etc/postgresql/11/main/postgresql.conf

I followed this guide to upgrade Baserow: Install with Docker // Baserow. In the terminal, it says I can upgrade Baserow to 1.24.1. But Baserow is not running still. I am getting the below error.

Welcome to Baserow. See for detailed instructions on 
how to use this Docker image.
sed: can't read /etc/postgresql/11/main/postgresql.conf: No such file or directory
 [STARTUP][2024-04-12 03:10:21] Running setup of embedded baserow database.

I have the same issue, Baserow updated, it was broken, found the upgrade instructions, got the green light that the update went ok, but then just this error message

Figured out one way to solve it. Was trying to do it via changing the image name in Cosmos (a docker hub thing), that did not work, have to use the command line commands as in the help text. After that I had to totally remove my baserow inside cosmos (except the volume) and recreate it from the market with the old volume.

I have the same issue.

I am using Portainer to manage my docker containers and I have installed baserow 1.23.2 self host. It worked well.

I saw the baserow 1.24.2 latest version news and to update, I installed baserow 1.24.2 after baserow-pgautoupgrade success log, with Portainer, but it failed with the same error message in this thread.

How to upgrade to baserow 1.24.2 (from 1.23.2) under the Portainer circumstance?

I am using Poratiner too. For me, I removed the container then remade it and bind it to my volume and it worked just fine.

@Kimmy, thank you for sharing the solution! :raised_hands:

@hslee, did @Kimmy’s proposed solution work for you?

Thanks, I solved my problem with the method similar to yours.