Can't send Emails from Baser

I have installed a Baserow via a Docker Compose with coolify. So far everything works but when I set the env variables it does not send out any emails. I have set these settings.





Hey @Magicnetworks,

Gmail has strict rules for sending emails from devices or applications. Have you already checked their documentation?

There are also other threads about this topic in the forum, like this one:

Another thing you could try is to look at the logs to see which error Baserow encounters when sending the email or try using a different SMTP server with less restrictive rules to send emails.

I first tested it with my company email and that doesn’t work either. I don’t really see anything in the log either.

Is it important to put the email address in the square brackets?

It won’t work because GMail (both for personal use and with Google Workspace) does not allow it to be used as a plain SMTP email server. It used to be possible but not anymore (the justification is security-related and I concur with it).

If you want to send transactional emails easily, I suggest Postmark (not affiliated), which has worked fine for us for years.

I just noticed that the EMAIL_STMP=yes is missing.

From our documentation here: Configuring Baserow // Baserow

EMAIL_SMTP: If set to any non empty value then Baserow will start sending emails using the configuration options below. If not set then Baserow will not send emails and just log them to the Celery worker logs instead.

No i tested with my provider ionos an it doesn’t worked. I don’t know what I’m doing wrong. I tested with ssl tls, i took the parameter from the documentation. Port 487 because my server is from Hetzner and only 487 is not blocked. Can I create the user over the api for self hosted baserow?