Confused about Docker version requirements

The doc says that “Docker-compose version 3.4 and Docker version 19.03 are the minimum versions required by our provided files”… But my Docker says my version is “4.12.0” and up to date (“Docker Desktop 4.12.0 (85629) is currently the newest version available”), and that my Compose version is “v2.10.2”. Thus the requirements seem impossible, as 19.03 > 4.12.0 and 3.4 > v2.10.2. Some clarification would be welcome.

Note. I’m using macOS 12.5.1.

Apologies Docker-compose version 3.4 is not clear I agree and should instead read A docker-compose installation that supports the docker-compose file version 3.4. I’ll fix up this to be clearer. Docker Desktop is a different piece of software, with a different versioning scheme compared to docker itself. Compare Docker Desktop release notes | Docker Documentation and Docker Engine release notes | Docker Documentation.

1 Like

Thanks, this distinction between Docker Desktop and Docker Engine makes sense!