Connection Failed Alert Blocking Server Access

Hello everyone, I need help please

Self-Hosted Installation and Setup Questions

How have you self-hosted Baserow?

  • Docker

What are the specs of the service or server you are using to host Baserow?

  • 32GB RAM
  • 4 CPUs
  • 26GB disk space
  • Co-hosted with n8n

Which version of Baserow are you using?

  • 1.15.2

How have you configured your self-hosted installation?

  • Docker Compose
  • .env file
version: "3.4"
    container_name: baserow
    image: baserow/baserow:${BASEROW_VERSION}
    restart: unless-stopped
      - .env
      - "8085:80"
      - ${BASEROW_DATA}:/baserow/data
      - servernet

    image: postgres:11
    container_name: postgresBaserow
    restart: always
      - 5433:5432
      - .env
      - /opt/baserow/data/database/postgresql:/var/lib/postgresql/data
      - servernet

    driver: bridge






Describe the problem

I hope this message finds you well. I am currently facing a critical issue with my Baserow installation. An alert with the message “Connection failed” is blocking access to the server, severely impacting our work.

Problem Summary:

  • Alert: Connection failed, preventing server access.
  • Impact: Unable to work due to the alert.

In the logs, I found the following error:

[2023-11-24 09:23:00,023: INFO/MainProcess] Scheduler: Sending due task baserow.core.notifications.tasks.beat_send_instant_notifications_summary_by_email() (baserow.core.notifications.tasks.beat_send_instant_notifications_summary_by_email)[2023-11-24 09:23:00,029: INFO/MainProcess] Task baserow.core.notifications.tasks.beat_send_instant_notifications_summary_by_email[562742c4-4577-48b9-88a5-6817414b0fea] received[2023-11-24 09:23:00,036: INFO/ForkPoolWorker-1] Task baserow.core.notifications.tasks.beat_send_instant_notifications_summary_by_email[562742c4-4577-48b9-88a5-6817414b0fea] succeeded in 0.003708976088091731s: None[2023-11-24 09:23:00,037: INFO/MainProcess] Task baserow.core.notifications.tasks.singleton_send_instant_notifications_summary_by_email[ec260f22-181a-417b-b3da-05117981a5ae] received[2023-11-24 09:23:00,049: INFO/ForkPoolWorker-1] Task baserow.core.notifications.tasks.singleton_send_instant_notifications_summary_by_email[ec260f22-181a-417b-b3da-05117981a5ae] succeeded in 0.009235595818609s: None
 (400 Bad Request)

I would appreciate any assistance in identifying and resolving this issue.

Capture d’écran du 2023-11-24 10-51-57

Hi @MickaRak, I’m sorry to hear that you’re having some problems. The message means that the web-socket can’t connect to the server. Do you have a proxy, load balancer, or anything similar in front of your Baserow instance? It’s usually because there is a service in between that doesn’t support this.

Hello @bram , thank you very much for your feedback
Yes, I have a reverse proxy on my server, before with the old version it still worked and everything worked when I upgraded and there was this bug that appeared, I don’t know what config was going on at the level and so on, but the action I did, other than bridge networking and then reset, was only the version upgrade.

Can you elaborate more on the reversed proxy that you have on your server? It would be useful to know which one that is, and what kind of configuration you have there. Some other comments:

  • Based on your environment variables, it seems like you’re running version 1.15.2 of Baserow. Is that correct? The latest version is actually 1.21.2.
  • Why have you enabled the OTEL, and why is OTEL_EXPORTER_OTLP_ENDPOINT the same as the BASEROW_PUBLIC_URL?
  • I am not 100% sure if Baserow can run on subpath. Is there any chance you can run Baserow on a dedicated domain like

Hello @bram

For the reverse proxy, baserow’s ip works with the IP 10.X.Y.2 and the environment where it’s hosted is the same network address with 10.X.Y.218 so baserow is pointed to the second 10.X.Y.218 with a port that differs from n8n which is 5678, the two projects baserow and n8n are on the same server and n8n’s address is 10.X.Y.218:5678 under Other than that, I don’t have any control, it’s on the production side.
At the moment, I’ve upgraded to version 1.21.1 where I’ve encountered this problem with the notification blocking.
OTEL, it’s a configuration I found in the documentation and I’ve applied but I’m not sure I need it, can you give me an example of good practice for installing baserow under docker please?
Yes, exactly, this is the baserow url I use with this subdomain, and it worked with 1.15.2 version when I upgraded to version 1.21.2, I encountered this problem

If you’re not sure about what the OTEL environment do, then you don’t need them. I would remove them.

Instructions for installing on Docker can be found here: Install with Docker // Baserow.

So, if I understand correct, your Baserow environment is currently running on a standalone domain (

Can you please send me a screenshot of your browser network tab? On Firefox, you can open it by doing: Press Ctrl + Shift + E (Cmd + Opt + E on a Mac). Make sure that the WS option is active, and that you refresh the page after opening the tab. It looks like the screenshot below.

It would also be great if you can share the configuration of your reversed proxy.