Could Not Connect to API Server


I am newbie to Linux and not developer. I would like to try self-hosted Baserow but i get error upon Signup (Could not connect to API server).

Below first attachment is my configuration and what i have achieved so far.

Upon investigation: (Installing Baserow behind Nginx // Baserow)
i think it is proxy issued (WebSocket Conflict) with my NGINX PROXY MANAGER.
Installing Baserow behind Nginx // Baserow

Below is what i have not yet taken any Action.

Could you help me out to solve the issue?

Please fill in the questionnaire below.

Help Questionnaire

Self-Hosted Installation and Setup Questions

Delete this section if you are using

How have you self-hosted Baserow.

What are the specs of the service or server you are using to host Baserow.

Which version of Baserow are you using.

How have you configured your self-hosted installation?

What commands if any did you use to start your Baserow server?

Describe the problem

Describe, step by step, how to reproduce the error or problem you are encountering.

Provide screenshots or include share links showing:

How many rows in total do you have in your Baserow tables?

Please attach full logs from all of Baserow’s services

1 Like

Im running into the same issue. Via HTTP (no https) i was able to get it working but then with no changes it stopped again… then worked again… made working on the project frustrating.

Hi @ratanainfo, what’s the full value of your BASEROW_PUBLIC_URL environment variable?

1 Like

hello bram

sorry i overlook your respond.


You may find other information in the Portainer Stack

Hi @ratanainfo, no worries. I think you would have to change your BASEROW_PUBLIC_URL to to make it work. It must include the port number.

Hello bram,

I manage to change stack with your recommend BASEROW_PUBLIC_URL to, unfortunately, it is not working.

On the other hand, i go directly to IP address of my baserow docker, i also get the same error Welcome page of Baserow, but once I fill up to start…ERROR occur, CANNOT CONNECT TO API SEVER. Thus, it seems Baserow issue.

i also try other value, but also not working, as below screenshots.

Hey @ratanainfo,

Looking at your configuration you should be using your url to access Baserow, For your env options set BASEROW_PUBLIC_URL and don’t include the 8585 port as it isn’t really needed unless you want to use a different port but I would advise against it for now.

Then in Proxy Manager you will need to set the url to point to http, the name of your baserow container and port 8097 which looks like what you have and from here you should be good to go.

This is how I have Baserow running in Portainer along with nginx proxy manager with no issues.

Hello @joffcom

Well i change my configuration with your advise. yet i receive that same error (Cannot connect to API Server) neither URL nor Direct IP.

Here is the screenshots.

Hey @ratanainfo,

You still have that port in there, do you need to use that? I suspect that is causing the issue. If you open the browser dev console then try to complete the form are you seeing a cors error?

Hi @ratanainfo,

I’ve visited your Baserow instance ( myself, and tried to create an account. I noticed that when Baserow tries to do an OPTIONS request of the /api/user/ path, it fails either with a NS_BINDING_ABORTED or CORS Failed error.

Could this somehow be related to your NGINX proxy settings? Maybe it doesn’t allow OPTIONS requests? It seems like Baserow is working as expected here.

Hello @bram
Well, since i am newbie(and Not Developer) I really do not understand the flow well. Pls assist by finding with solution :-).

On the other hand, as i have shared above i get the same experience (Error) with direct IP access to Baserow.

If i get direct IP access to baserow, it should not follow Nginx Proxy Manager anymore, right?

Hi @ratanainfo, to be honest, I have no clue about how your proxy, server, etc is configured, this makes it difficult to help. I’m willing to help, but you would need to share more information about your configuration.

Hello @bram

What kind of information? Pls advise. It seems i have nothing else to Share.

Here is my configuration shared in Post 6.

Hi @ratanainfo, I don’t have any experience with Portainer or the NGINX proxy manager I’ve seen in your screenshot. I would be able to read an NGINX configuration file, and maybe get some insights from there. But I don’t know where you can get it, or how you would update it. If you also don’t have experience with these tools, then I don’t think I’ll be able to help you with this.

Perhaps you can ask for help in the Portainer community because your problems seems unrelated to Baserow.

Alternatively, if you want to self-host Baserow, but you don’t have that much experience with doing so, then I recommend using Cloudron (Baserow on Cloudron). IMO it’s the easiest way of fully self-hosting Baserow. You just have to press a button and then it works.

Hello @bram

Noted with many thanks.

Really appreciate for your kindly help. I will try to explore more.