could not connect to the api server

I installed baserow in docker and I can’t register in any way.
I’ve already tried all possible options, and it’s still a mistake

Hi @mag106,

please tell us exactly how you run Baserow.

I run from Docker

BASEROW_PUBLIC_URL - I tried to specify all possible options, the error is always the same

@petrs I reinstalled it again on a clean system - I specified the ip of the machine from which I log in. but I keep getting an api error
docker run -e BASEROW_PUBLIC_URL= \

–name baserow
–restart unless-stopped
-v baserow_data:/baserow/data
-p 80:80
-p 443:443
–restart unless-stopped
Unable to find image ‘baserow/baserow:1.15.2’ locally
1.15.2: Pulling from baserow/baserow
3f9582a2cbe7: Already exists
5d7e3615976f: Pull complete
360a0c7a002c: Pull complete
d1e684a89df1: Pull complete
1d368776cec3: Pull complete
53d9ab344835: Pull complete
5d60bc9585cc: Pull complete
81224aa103b7: Pull complete
6e5ca0a031ba: Pull complete
51e805c63f53: Pull complete
92696ff6e5ec: Pull complete
Digest: sha256:063ab87ea6b28e69619a9560e41b76585db57485af44a57661c98d299b721960
Status: Downloaded newer image for baserow/baserow:1.15.2

Have you tried running exactly the command from the documentation:

docker run \
  -d \
  --name baserow \
  -e BASEROW_PUBLIC_URL=http://localhost \
  -v baserow_data:/baserow/data \
  -p 80:80 \
  -p 443:443 \
  --restart unless-stopped \

This command alone should start Baserow locally on your machine.

In your first screenshot, this variable is empty. In your second example, you set it to which might not be the correct value.

What is the URL where you access the Sign up page in the browser? Can you open browser developer tools and see/screenshot the failing HTTP request?

@petrs I figured it out, it turns out that you need to specify not only the address but also the port, even if it is dropped! Is it possible to disable this protection and make it available to any address ?

Is it possible to disable this protection and make it available to any address ?

Are you referring to BASEROW_PUBLIC_URL? Are you using non-standard port for http/https?

@petrs on the server, I use standard ports, but when connecting, I forward port 8008 to 80 on the router, and accordingly, so that I could connect, I copied the line from the browser to BASEROW_PUBLIC_URL