In my self-hosted instance, when accessing the data where query parameter ‘size’ is set to be greater than 200, this error is received.

It seems like a bug, as the purpose of this parameter is to be able to set any custom value, right?

How to resolve this for now?

Hi @shrey, by default the maximum amount of rows that can be requested via the API is indeed 200. The size parameter can be used to choose if you want to change the requested page size. So if you for example just want to request 10, you can set it to that number and no more than 10 rows will be returned.

The maximum amount of rows rows that can be requested can be changed if you’re self hosting. This can be done via the BASEROW_ROW_PAGE_SIZE_LIMIT environment variable. More information about all the available env variables can be found here: Configuring Baserow // Baserow.

In your case, you basically need to set BASEROW_ROW_PAGE_SIZE_LIMIT to maybe 400, restart your instance and then use the size parameter to request more rows.

Hi @bram , thanks for the info!