Error in File field


I am using a self-hosted Docker instance on a Synology NAS.

The database is up and running and seemingly working well.

Until I try to add a file, whether it be a PDF, image, or any other type to a File field.

Then, I get an error The action couldn’t be completed because an unknown error has occurred. The thumbnail of the file I am trying to upload shows properly in the modal dialog box, but when I click on Upload or Retry, this error occurs.

I would appreciate any help! Thank you.

I “solved” my problem by changing folder permissions. But I am unsure why this was required in the first place, and I am wondering if I did the appropriate thing.

For reference, here is my docker compose stack in Portainer:

version: '3.3'
        container_name: baserow
        network_mode: bridge
            - 'BASEROW_PUBLIC_URL='
            - '/volume2/docker/baserow/data:/baserow/data'
            - '9988:80'
        restart: unless-stopped
        image: 'baserow/baserow:1.13.1'

Just deploying that container allowed baserow to run, but gave me errors when trying to access the disk (exporting CSV file, adding any files to File fields, etc).

I solved the problem by navigating to the /baserow/data folder and running

chmod 777 *

Here is a screenshot of before and after I did the chmod. I am hoping someone will be able to tell me what I did wrong when deploying the container such that I needed to change permissions like I did.

I am concerned updating the container will negate or change what I have done, so ideally I’m looking for a solution that would permit me to “start again” by deleting my baserow folder (I have only test data there) and re-installing from Portainer with everything working properly, and no chmod required.