Error Message: 'ERROR_MAX_JOB_COUNT_EXCEEDED' When Creating Tables in Baserow on AWS ECS Deployment

I recently deployed Baserow, on AWS using the ‘install with Docker Quick Starts’ method without an external database or Redis. The deployment worked without issues. However, when I attempted to deploy Baserow on AWS Elastic Container Service (ECS) using the ‘install on AWS configurations’ with added Amazon RDS for PostgreSQL and a Redis cluster, I encountered a problem. Specifically, I’m now receiving the following error when attempting to create a new table:

detail “Max running job count for this type is exceeded.”)

I’m seeking guidance to understand and resolve this issue. What could be causing this error, and what steps should I take to resolve it?

Hi @aditmodi,

I don’t think creating new tables use the job system that produces the ERROR_MAX_JOB_COUNT_EXCEEDED error.

Can you provide more information as a full stack trace, where you are seeing this error, etc.?

yes, @petrs , I was seeing this error when i was deploying my application on ECS and when i try to upload new table with data, in the inspect element, request/response in the network option, I was seeing it.

Again, I made changes, one S3 didn’t have proper ACLs added that. Now, I am no longer running into above issues but am getting:

logger": “http.log.error”,
“msg”: “dial tcp connect: connection refused”,
“err_trace”: “reverseproxy.statusError (reverseproxy.go:886)”

I have not set the BASEROW_JWT_SIGNING_KEY, could be because of that.

still running into the connection refused error for port 8000, unable to understand what mistake I am doing.

I am not getting this error when i run a single service/task on ECS, but when increase the task to 5 and put on Autoscaling, this issue arises. I added JWT but this still causes issues.

These error results in my task getting stopped. In general, my service spawns new tasks to run baserow. I have autoscaled it to 5tasks.

one task works for about 30mins and then the elb becomes unhealthy and task goes to stopped stage and in the cloudwatch, i get above error about connection refused error for port 8000.

@aditmodi can you provide your task defintions, screenshots showing how you’ve configured your ELB, screenshots showing how you’ve configured your various container heath checks, screenshots showing your ECS config and full container logs from these containers.

yes @nigel .

My ECS Task Definitions:
I am using EC2 instead of Fargate for this. My Hard/Soft Memory limit is 2048/512Mib.
All envs are stored here. I have used EFS for mounting my file system.

ECS service is pretty standard with autoscaling on memory and cpu usage. my health check is load balancer with health check endpoint being “/api/_health/”

unable to add images here.