Failure of Installation on Docker Desktop of M1 Mac

Hi all,

I’m struggling with installing the latest version (1.9.1) of baserow on Docker Desktop of Mac (running on an M1 MacBook Pro).

I had installed previous version (1.5 to 1.7), by following an official instruction (now deprecated) involving docker-compose function, and it had just worked fine. Yet I accidentally removed the installation recently, so I tried to follow the current instructions (installation with docker, installation with docker-compose, and configuring baserow).

However, it just failed: I firstly tried to use both and docker pull request, docker run command and it just failed to fully installed (there are some error messages mentioning arm64). Then I tried to follow the docker-compose instruction, with an .env files (containing a randomly generated SECRET_KEY, DATABASE_PASSWORD and REDIS_PASSWORD; other options remained default/blank); the installation went without giving error messages, yet there it still failed operate as I cannot access the baserow login interface via localhost:443.

It might be noteworthy that there are some “sub-apps” (disclaimer: I’m not a tech guy and totally unfamiliar with coding and docker) inside of the baserow containers showing that they’re for amd64 and might not work properly under arm64 architecture.

I’m not sure what I could try next, or what kind of error messages/screenshots/any types of info that I should upload here to help tackle with the problem. Any suggestion?

Hey @wilsonkao,

The official images don’t currently support arm unfortunately. I have made issue to add support: .

For now I believe it used to work for you because the old docker install had you build your own images. The new one instead uses our pre built ones. You could however easily try building your own ones like before which hopefully works:

git clone
cd baserow 
docker-compose -f docker-compose.yml -f docker-compose.local.yml up --build

This uses the extra local.yml docker compose override yaml file which forces it to build the images locally and not use our pre built ones. You will probably want to delete from this file the mailhog service and the celery environment section which configures the celery service to send emails to mailhog. Mailhog is for local testing of Baserow emails and you will probably want to use your own real email server. Finally any docker-compose command you run should start with -f docker-compose.yml -f docker-compose.yml to ensure it is using the local override.

Let me know if you have any issues!