Field name is missing from "Hide Fields"

I’m using for a 515-row table. Today, the field name for the left-most column stopped appearing when I click the Hide Fields option. Also, clicking the field name reveals a much shorter list of possible actions than for other fields.

The field data continues to be present and exportable. I have a copy of the table saved from a week ago and that copy is exhibiting the same new, unusual condition.

How do I restore the ability to hide that field?


The left-most column in a baserow table is the primary key of that table and is normally used to have a unique value for each row. This is the reason why the field cannot be hidden and that it cannot contain a link to another table. This should be the normal behaviour of the Name field.

A workaround is that you change the name of that column to ID, make it of the type formula and use the function row_id(). Next, you can create a new column ‘Name’ and you will be able to hide it and work with it like any other column.


More information about the Primary field can be found in the user docs here.

My bad. It isn’t the primary key column, it is the one next to it. I should have said: the left-most user-created field.

Ok, no problem.
Can you post a link to a screencast that demonstrates the problem?

Just quick notice: I found out some time ago, that some field types do not offer the filter/sort/hide options via context menu. But it still can be achieved if going directly to filter/sort/hidden fields functions (I mean buttons in the upper bar