Field value is not updating real-time automatically via link field between 2 tables

Hi there?
I found a baserow yesterday, so I tried to install it locally via docker image, so it works fine.
But I found a super big problem.
Let’s say, for example, I have 2 tables named “Clients” and “Services”.
And I have a “Name” field in Clients table, and its linked to “Client name” field via Link type in Services table, so I can see clients name in Services table.

BUT!!! I have a super big problem.

I opened 2 tabs with Clients and Services table on my browser.

When I update Name field in Clients table, changes should be applied automatically in to “Client name” field in Services table like airtable.

At the beginning, I expected, it will be updated real-time automatically, BUT!!! Nothing happened.
I will have to refresh a web page(Services table) manually every time to check any changes.

I think , this is really critical problem or am I missing something?.
Please help me.
Thank you so much. :+1:

Hey @Long :wave:

I have checked this with the dev team, and this feature has not yet been implemented. However, we already have an open issue for it: Support sending changes to dependant cells in realtime (#501) · Issues · Baserow / baserow · GitLab.

I will also discuss with the team if we can prioritize this feature.

Ah yeah, I see.
I saw this on landing page. So I thought, this is done already.
Thank you so much! Great @olgatrykush
I really really appreciate your efforts.
Can I know when will it be implementing?

Can I know when will it be implementing?

I will check with the team to see if we can get an approximate timeline. Either way, I will let you know later.

I will be waiting for your positive reply.

Hi @olgatrykush
Do you have any news from your team for real-time updating feature?
Thank you.

Not yet @Long. I’ll share the update once I have any news. :raised_hands:

2 posts were split to a new topic: Issue with importing data to Baserow

Hello @olgatrykush :clap:
Sorry to bother you.

I have another critical issue with using an API.
I have imported all rows successfully from Airtable to baserow using a script that I built.
But only 1 row has an issue, when I try to create a new row using baserow API, it keeps returning a 500 internal error. :sleepy:
So far so good, but only 1 row is a problem.

So, I tried to create a row using Postman,
As you can see, the request body is correct.
I have the Clients and Orders table.
In the request body, the “Client” field is linked to the Clients table, so I added the row id of the Clients table as an array.
7988 row ID is available in the Clients table.
Weird thing is if I remove “Client” array from body json, api works fine. :thinking:
I have created over 6000+ rows in the Orders table with links to the Clients table.
But only this row is not creating with 500 internal server error.
I don’t understand what’s wrong.
I am fighting this problem for a few hours. Omg!
Please let me know what I am missing / what’s wrong.

Thank you so much!


I found the 500 error problem.
It was because of lookup field in baserow. Hmmm…

When I have lookup fields and try to create a new row using api, it keeps returning 500 internal error.
Once I removed lookup fields and a new row was created successfully via api.

[POSTGRES][2024-02-27 07:27:46] 2024-02-27 07:27:46.862 UTC [78317] baserow@baserow ERROR:  cannot extract elements from a scalar
 [BACKEND][2024-02-27 07:27:46] - "GET /api/_health/ HTTP/1.1" 200
 [BACKEND][2024-02-27 07:27:46] ERROR 2024-02-27 07:27:46,865 django.request.log_response:241- Internal Server Error: /api/database/rows/table/522/
 [BACKEND][2024-02-27 07:27:46] Traceback (most recent call last):
 [BACKEND][2024-02-27 07:27:46]   File "/baserow/venv/lib/python3.9/site-packages/django/db/backends/", line 89, in _execute
 [BACKEND][2024-02-27 07:27:46]     return self.cursor.execute(sql, params)
 [BACKEND][2024-02-27 07:27:46] psycopg2.errors.InvalidParameterValue: cannot extract elements from a scalar
 [BACKEND][2024-02-27 07:27:46]
 [BACKEND][2024-02-27 07:27:46]
 [BACKEND][2024-02-27 07:27:46] The above exception was the direct cause of the following exception:
 [BACKEND][2024-02-27 07:27:46]
 [BACKEND][2024-02-27 07:27:46] Traceback (most recent call last):
 [BACKEND][2024-02-27 07:27:46]   File "/baserow/venv/lib/python3.9/site-packages/asgiref/", line 486, in thread_handler
 [BACKEND][2024-02-27 07:27:46]     raise exc_info[1]
 [BACKEND][2024-02-27 07:27:46]   File "/baserow/venv/lib/python3.9/site-packages/django/core/handlers/", line 43, in inner
 [BACKEND][2024-02-27 07:27:46]     response = await get_response(request)
 [BACKEND][2024-02-27 07:27:46]   File "/baserow/venv/lib/python3.9/site-packages/django/core/handlers/", line 253, in _get_response_async
 [BACKEND][2024-02-27 07:27:46]     response = await wrapped_callback(
 [BACKEND][2024-02-27 07:27:46]   File "/baserow/venv/lib/python3.9/site-packages/asgiref/", line 448, in __call__

See this guy has the same problem.

  1. Can I know why this happened?
  2. This sounds like I can’t use lookup fields??
  3. Have your team fixed this problem in a new version or not?

Please let me know.

Hi @Long, would you be able to share more details about your database schema when this error happened? It looks like a bug in the lookup field, but us it’s important to be able to reproduce the problem to fix it.

Sure, how can I share it with you?

Hey @Long, currently, this feature is a low priority for us, and we decided to leave its position as it is. However, if we receive more requests or comments about it, we will reconsider its priority.

You can monitor the status here: Support sending changes to dependant cells in realtime (#501) · Issues · Baserow / baserow · GitLab

I’ve been asking for it too!

Noted, and thank you for letting us know, @TheLorax. As we see more users asking for specific features, we try to prioritize them higher. :raised_hands: