How to fix rollup that needs forced recalculate

Hello, please help me to fix a rollup problem

Describe the problem

My rollup field needs to be forced to recalculate so that it correctly sums the data in the linked table.

Describe, step by step, how to reproduce the error or problem you are encountering.

Using a flow in, I post 10 rows of data to table x in my BaseRow database

  1. I manually check and confirm that data has been correctly posted to table x
  2. I manually check table y and see that the rollup in table y only sums some of the rows in the target field in table x
  3. I manually edit the rollup field in table y and change the number of decimal places
  4. The rollup in table y correctly sums the data in table x

Provide screenshots or include share links showing:

How many rows in total do you have in your Baserow tables?

99 rows in all tables

Please attach full logs from all of Baserow’s services

Hello @leithh, first of all, welcome to the Baserow community :wave:

Could you please add some screenshots so we can better understand what you’re trying to do? I’ve changed your trust level, so now you should be able to add images to your posts. :ok_hand:

Hi @olgatrykush thanks for your response. Please see the screenshots. Note that they show the correct values after forcing the rollups to recalculate.

This is what I’m trying to do

In the ‘Sprint’ table I’m trying to rollup simple integers from the ‘Issues’ and ‘Capacity’ tables.

The data in those tables is populated with a ‘create row’ API. The ‘Issues’ data is batched in so I assume the rows are populated in one hit.

The 'Capacity data is populated by members using a form so they come in one-at-a-time. But, when I check the ‘Sprint’ table, the ‘story_points’ and ‘capacity’ rollups display an incorrect sum.

  • I tried refreshing the browser window → no change
  • I tried logging out of BaseRow and back in → no change
  • I edit the rollup by changing the number of decimal points → the correct values display
  • I edit the rollup to revert to the original number of decimal points → the correct values display.

I want to eliminate manual actions, so how can I get my rollups to recalculate as they should?

Many thanks, Leith

Thanks for sharing the screenshots, @leithh. We will look into the issue. :ok_hand:

Hi @leithh, I’m trying to reproduce your problem, but for me, the rollups are calculated in the correct way. The rollups use a SUM function, and I’ve tried to submit the data using a form and via the bulk API endpoints. See the videos below. Am I doing anything differently compared to you?

Everything should update in real-time without having to save the rollup field again.

Hi @bram and @olgatrykush, thanks for your help.

I noticed that the order in which you view the tables in each instance is different to the order I follow. I repeated our usual process but changed the order in which I manually check the tables afterward. Instead of looking at the sprint table and watching for the rollups to calculate and then checking the issues and capacity tables, I reversed the order. So, if I check issues and capacity tables first, when I open the sprint table the rollup has correctly summed the relevant fields.

Let’s resolve this. Thanks again for your help.