I am not able to sync my airtable base to baseraw. Timeout error

Can you please increase timing so i can import my base?

Please fill in the questionnaire below.

Technical Help Questionnaire

Have you read and followed the instructions at: *READ ME FIRST* Technical Help FAQs - #2 by nigel ?

Answer: No I have not

Self-Hosted Installation and Setup Questions

Delete this section if you are using Baserow.io.

How have you self-hosted Baserow.

What are the specs of the service or server you are using to host Baserow.

Which version of Baserow are you using.

How have you configured your self-hosted installation?

What commands if any did you use to start your Baserow server?

Describe the problem

Describe, step by step, how to reproduce the error or problem you are encountering.

Provide screenshots or include share links showing:

How many rows in total do you have in your Baserow tables?

Please attach full logs from all of Baserow’s services

Hello @369, welcome to the Baserow community :wave:

Can we ask you how big your database is?

How can I measure? I have more than 6,000 lines with around 30 columns and have 4-5 tables. Have pictures attached, receipts. If you can extend the time then I would be able to sync it to baseraw

Good morning @369,

Ordinarily, that kind of import should be processed relatively promptly, but as you have a lot of media, it’s possible that it’s causing the import to take longer than our 30-minute cut-off.

A quick fix would be to temporarily increase the BASEROW_JOB_SOFT_TIME_LIMIT setting (documentation available here) to 45-60 minutes, and trying your import again.

I hope this helps, have a great day!


in which file should I add BASEROW_JOB_SOFT_TIME_LIMIT ? is it in env.sh ? I use docker in cloudron

Hello @369 - apologies for the slow reply. Yes if you put BASEROW_JOB_SOFT_TIME_LIMIT=NEW_VALUE into your env.sh then all of your jobs, including importing Airtable bases, will now have a maximum duration of NEW_VALUE.