Importing from Airtable, CSV

I have three tables with 300-400 records each in Airtable that I would like to move to Baserow.

I get an error when trying to import the Airtable base (Error message: Something went wrong during the airtable job execution.) I understand it is beta, but can I somehow troubleshoot what went wrong with import (I am not using the selfhosted version of Baserow)?

I tried to import the tables as CSV. That worked fine, but is there a way to automatically link the three tables in Baserow? They all have key fields,

I saw this post

But using n8n is unfortunately to complex for me.

Hello @bonordlin, first of all, welcome to the Baserow community :wave:

The Airtable import doesn’t work as of now, because Airtable made some changes on their end that required us to make some changes as well. We have already fixed it (, and it will be included in the next release. Sorry for any inconvenience that may have been caused! :slightly_smiling_face:

What about Make or Zapier?