Installation port on Dockers (windows 10)


i downloaded Baserow latest version in dockers desktop (windows 10).

Then in power shell i ran the container at port 80. it works.

now on another laptop i did same step except i changed port to 3000:80

It went to login page and when trying to create account it says API server not found.

Repeated and reproducible issue.

Hi @verifybudi

Did you set the WEB_FRONTEND_PORT and BASEROW_PUBLIC_URL to point to your new port.

Also could you try using a different port other than 3000, 5432 ,1085 and 8000 as I believe those are already bound within the docker container.

for the ports i tried already 3001 but still the same error “API server not found”

Didn’t have any problem with budibase or Grist installation. They don’t ask me to set any frontend or public url , no matter which port i set.

I shall try to set frontend/ public url to and see.

probably Baserow can look into budibase/grist installation steps so installation doesn’t need extra parameters. Regards

The server is on Laptop.
Laptop has ip


When i connect LAN Cable i can open on Laptop and any other LAN PC. but as soon as i remove LAN cable and try to open using localhost:3001 on Laptop i get this error.

why localhost:3001 fails on Laptop(server)? How to fix?