Webhook Integration Issue


I am a non-tech person and very new to Baserow. I have an issue I am facing.

Have imported a database from Airtable.

  1. Created a webhook. It detects successfully in if I uncheck - Use field name instead of ID option.

  2. If checked it sends an error on the BASEROW side of ACTION NOT COMPLETED.

  3. On the side, once I connect the webhook to the Baserow module, the result shows an error message -

I have been stuck on this for days without a solution. Searched for the solution everywhere.


Thank you.


Welcome to the community!

Can you clarify your scenario a bit more? I tried the following steps and it seems to work:

  1. Create a new scenario in Make

  2. Add a webhook (a custom webhook)

  3. Copy the url of the webhook. It starts with

  4. Go to Baserow and click the 3 dots next to the table where you need the webhook to react

  5. Select Webhooks

  6. Click Create webhook +

  7. Offer it a name you pick yourself

  8. Paste the url, you can leave the method to post

  9. Select which events you want the hook to repsonse. This can be everything, or a combination of create, update and delete

  10. Save the webhook

  11. Go back to Make and start your scenario

  12. Go back to Baserow and insert a new record

  13. Go back to Make and check if there is a response

You should see something similar to this

From here on you can continue with your scenario in Make. I assume from the screenshot that you are trying to get the row from Baserow again, but this is not necessary since the entire row is already stored in the items response of the webhook.

Please let me know if you need further assistance with this.


Hello @frederikdc, Thank you for taking the time out.

I followed all the steps and what’s happening is as soon as I select - User field names column.

The signal is not captured by Make.

The moment I uncheck, it does with a 200 OK status

What’s the solution for this?


I was not able to reproduce the error message. It worked with both the checkbox on or off. I think there are a couple of things you can try:

  1. Check the type of webhook you selected and make sure it is a custom webhook

  2. Detach further nodes in Make from the webhook te be sure that the webhook is responsible for the error.

  3. Delete the webhook from your table and try again (can be with a different table).

  4. Delete the webhook in Make and create a new one