No connection to api-server after update

Hi,

I just updated baserow and finally I get no api-connection after trying to login.

Any idea?

I updated with

sudo docker run -d --name baserow_version_1.21.2 -e BASEROW_PUBLIC_URL=https://myurl:3001 -v baserow_data:/baserow/data -p 3001:80 --restart unless-stopped baserow/baserow:1.21.2

Thank you and best regards

Hi @Martin, have you changed any environment variables when doing the upgrade? If not, would you mind sharing a screenshot of the output of your browser’s network log?

Hi bram,

thank you for your response.

Which environment variables do you have in mind?
I checked the path of the old and the new version and it is still the same.

Regarding my browser’s network log I found this guide.
But right now I am not sure if I understand right or if this is, what you need know, because I don’t know from which part of the created log.txt I should share a screenshot …
Too many lines … :man_shrugging:

Best regards
Martin

Hi @Martin, I didn’t have any environment variables in mind, I was just curious if you changed some when doing the upgrade to the latest version.

I was actually just looking for a screenshot of the output of your console after trying to login. Like the one below. You can open it in Firefox by right clicking someone on the page, click inspect, and then on console tab in the opened window.

Hi @bram ,

thank you.
I made two diffrent screenshots from firefox and safari.

firefox

Passwort-Felder sind auf einer unsicheren (http://) Seite vorhanden. Dies ist ein Sicherheitsrisiko, durch das Zugangsdaten gestohlen werden können.
login
Quellübergreifende (Cross-Origin) Anfrage blockiert: Die Gleiche-Quelle-Regel verbietet das Lesen der externen Ressource auf https://myurl/api/user/token-auth/. (Grund: CORS-Anfrage schlug fehl). Statuscode: (null).

safari

[Error] Es ist ein SSL-Fehler aufgetreten. Eine sichere Verbindung zum Server kann nicht hergestellt werden.
[Error] XMLHttpRequest cannot load https://myurl/api/user/token-auth/ due to access control checks.
[Error] Failed to load resource: Es ist ein SSL-Fehler aufgetreten. Eine sichere Verbindung zum Server kann nicht hergestellt werden. (token-auth, line 0)

Is it because of
BASEROW_PUBLIC_URL=https://myurl:3001
as a variable and because I have no ssl-certificate?

The BASEROW_PUBLIC_URL environment variable value must match the exact URL in your browser. Otherwise, it could result in CORS errors. Are they both the same?

1 Like

I run another container without the “s” in the BASEROW_PUBLIC_URLand it works. :blush:

Thank you.