Retool connection Through REST API

Hello everyone,

I wanted to connect my Baserow database with Retool. Followed all the steps along and looked that the authetufucation is correctly, but it didn’t work out, no matter what I tried.

I looked up the resources and made sure I filled out the necessary fields correct for connecting.

Unfortunatley I get the error “Permission denied” as you can see in my screenshot.

For the screenshot I changes the token to ‘xxx’ but normally I typed the right one in.

Thank you in advance



The message PERMISSION DENIED means that your token is valid, but has not the permission for the operation. Can you check if you have set the read permissions on for your database?

Hi Frederik,

thank you.

yes all the permissions are given…

Ok, I tried to simulate the problem and I think you might have copied the token from the wrong workspace.

An invalid or unrecognised token results in the message “Authentication credentials were not provided” or “The provided token does not exist”.

The only case that returns a “permission denied” error is when you use a token from a different workspace.

okay, but I only have one workspace, how can it be the wrong one?

I generated swell another token and changed it in the resource space and the query, but I get the same error

It might have to do with the fact that you authorise twice. You only need to do it in the resource like this:

This allows you to reuse the settings in all your API requests. The actual request looks like this:

Have you added the Authorization header to the resource?

Hey @frederikdc Frederik,

yes I have…

I really don’t know what to do anymore…

Thank you for your help