Row identifiers missing/different on Ipad/Chrome compared to Windows/Chrome desktop

Just starting using baserow a week or so ago and all was great but a day ago I found that the view of my single table (with 34 rows) was acting weird on IOS/Chrome.

All seems fine on Windows Chrome desktop.

From the images below (Windows first, IPad second) you can see that on the IPad several rows have no identifier and a most have Row Identifiers that are different to what being shown on Windows.

I have tried (all on Ipad)…

Logging in and out of baserow
Refreshing the page.
Killing and restarting chrome on IOS.
Clearing the browsing data and history.
Duplicating the table (New table is still screwy on the iPad).

Nothing seems to make any difference.

Not only can I not edit the rows with no identifier on the iPad I’m concerned that I am going to end up losing data at some point.

Any ideas what I can do?



Hello @arcaic, first of all, welcome to the Baserow community :wave:

Sorry for the inconvenience, we’ll check out the issue.

Any update on this? Would love to be able to carry on using

So i’m guessing this is some combination of smaller display size and/or running on a more “mobile” browser which we don’t currently test against. This will be a frontend/browser only problem so don’t worry about your data. Are you also not able to edit the cells themselves in the rows with no id?

I cannot edit rows without an ID visible.

I have tried this on a iPhone SE2 and an iPad 5th gen and its exactly the same on both. (the image above is from the iPad).

I have also tried on my Windows desktop using Chrome inspect with device set to iPad Air and it works fine, however when I set it to iPhone SE it is screwed like on the real device. No errors or output in the console.

Oh. Just tried on Safari on the iPad and its the same as for Chrome.


Thanks for the info will be very helpful trying to reproduce and fix!

This gets stranger. If I rotate the iPad to landscape and refresh the page all the IDs are shown. if I rotate it back to landscape and refresh the page then the IDs lower in the page are missing.

Not sure if that’s a help or hindrance but thought I’d mention it.