Signup not found. The selected signup wasn't found, maybe it has already been deleted

Hi, local install using and I had it working but then must have messed up the .env file… I reset the volumes and restarted the containers and now at:

I get this error:

.env file has:

Nothing in the docker logs… so I’ll be setting BASEROW_BACKEND_LOG_LEVEL=DEBUG next…


@garywong-bc have you seen and followed the instructions in the file itself?

# This compose file runs every service separately without any reverse proxy or http
# server to serve user uploaded files. It is intended as a starting point for people
# who want to use their own reverse proxy and run Baserow with one service per
# container. The web-frontend service is available by default at http://localhost:3000
# and the backend service is available by default at http://localhost:8000 .
# To use this file you need to:
#   1. Set the PUBLIC_BACKEND_URL to the URL that the user's browser can access the
#      backend service on.
#   2. Set the PUBLIC_WEB_FRONTEND_URL to the URL that the user's browser can access the
#      web-frontend service on.
#   3. Host the media files in the media volume on a HTTP server and set the MEDIA_URL
#      to the URL the user's browser can access the files on.
#   4. Ensure requests sent to the backend in /ws path are upgraded to websocket
#      connections.
# See the following guides for more details and example configurations:
#   1.
#   2.
# Also More documentation can be found in:

kk - I’ll try again. FYI in the absence of anything in the logs so far I’ve tried:

  • no BASEROW_PUBLIC_URL setting
  • BASEROW_PUBLIC_URL=http://localhost:8000
  • BASEROW_PUBLIC_URL=http://localhost:3000

I get different errors… and the strange thing is that I cannot find that “signup not found” string anywhere in the code… weird. I’ll keep trying.

The errors you are seeing are almost certainly because the javascript API client is failing to connect to the Backend API server.

You should be able to see this failure in your network logs.

Secondly, in your post above you’ve set BASEROW_PUBLIC_URL twice, are you sure you meant this?

Btw Are you using any form a reverse proxy instead of caddy?

I’m not using RP (as I’m spinning up, and no nothing shows up in the network logs (even with BASEROW_BACKEND_LOG_LEVEL=DEBUG). I suspected that maybe my on-prem instance was trying to communicate with a SaaS registration and failing as I’d already successfully run it with the same SECRET_KEY… but…

… well it’s obviously a ‘user error’… I had it working great but then tried to set up the SMTP email server settings, and somehow messed up the .env file… which of course is in .gitignore so I don’t have a version history.

sigh… gonna have to move onto another task… thanks @nigel from helping out and I’ll post up the resolution when I get back to it in the new year.

Best of the season to all… gary

P.S. I tried settings of BASEROW_BACKEND_LOG_LEVEL in turn (fresh install with reset DB)… didn’t mean to say I tried all settings simultaneously.

Are you trying to reach your Baserow server from a different computer’s browser? If so you need to see PUBLIC_BACKEND_URL and PUBLIC_WEB_FRONTEND_URL to the full qualified URL/IP + Port (it must start with http:// or https://) of the server you are trying to connect to, and not just localhost.

These variables tell the javascript frontend client where to find the backend API server and the nuxt SSR frontend server.

same computer… I have now (at the same time):


and the comms to the backend server (technically) works as I get the error msg… but again that msg “Signup not found” is so weird… it’s like some sort of DB validation error but I see the DB migrations complete successfully:

baserow-backend-1                   |   Applying db.0001_initial... OK
baserow-backend-1                   |   Applying sessions.0001_initial... OK

and definitely no error in any of the logs… oh well since I HAD it working before I’m confident I can trial-and-error my way back to a working .env file.

Out of interest as you are using docker what url are you putting into the browser? Are you putting localhost in there or an ip?


1 Like

Well that is all I had, good luck with the env options. Would love to know what you find out.

I feel like it is going to be something silly.

1 Like

Hi @garywong-bc

Apologies but after testing myself I found some typos in

I’ve made a fix for these on this page showing the changes:Resolve "Fix typos causing not to work out of the box." (!1182) · Merge requests · Bram Wiepjes / baserow · GitLab

and you can find the new version of the file in it’s entirety here:

I believe these fixes should solve your problem. You can also I believe just make sure in your .env file that you have set BASEROW_PUBLIC_URL= , that is you literally force it to be empty and this will fix your problem without changing your docker-compose.yml or waiting for the next version of Baserow with the fix made in the repo.

Finally, just so you know. Without a reverse proxy, nothing is serving your media files. Baserow uses Caddy to serve any uploaded images and files, so by default will not let you see uploaded files and images and you need to bring your own reverse proxy.

Are you sure you don’t want to just use the much much simpler and easier to use docker-compose.all-in-one.yml version?

Thanks @nigel … it works now!! And plse no need for the ‘apologies’ as you resolved it in < 24 hours… the community support is amazing and I love it.

Are you sure you don’t want to just use the much much simpler and easier to use docker-compose.all-in-one.yml version?

Actually, next up is the docker-compose.local-build.yml and then finally I’ll be ready to convert Install with K8S // Baserow to run on OpenShift4. I’m going in steps to understand the different services locally, and then on OpenShift.

thanks again!

1 Like