Submitting a Form

Hi - When trying to submit a form, it spins (image below) and never submits the form. I’ve tried 3 times, including using an incognito browser. Here is a link to the form: New Sale Form // Baserow

Screen Shot 2022-06-23 at 9.06.21 PM


Hi @mlee , sorry you hit this issue. Could you try remove theFinanced Amount from your form and see if that fixes the issue? Could you also let me know what type of field Financed Amount is so I can try reproduce the issue locally?


Hi @nigel - i removed that field (formula field) and I’m getting a different error now. I have tried other forms with less fields, and those work fine. I’ve also tried with and without the logo.


@nigel I figured out the issue. I’m unable to enter 0 into a number field on a form. 0 generates the error whereas 1 (or higher) allows the form to submit. Here’s a simple form to test the issue: Form // Baserow

Hope this helps.



Thanks a bunch for finding this bug! i’ll raise and issue and track it down :slight_smile:

1 Like

Hi @mlee , I was able to track down the formula related issue. Formulas atm aren’t supported in form views, however if you add another field type to the form and then update it to the formula type you can get around this check, which then breaks the form. I’ve made Updating a field to a type which isn't supported by a form view breaks the form view (#1078) · Issues · Bram Wiepjes / baserow · GitLab to track this fix.

Secondly I’ve tracked down the 0 error also and put it in this issue here: Cannot submit 0 values in a number field on a form view (#1079) · Issues · Bram Wiepjes / baserow · GitLab .

We hope to have both fixed soon!