Synology docker ...Network error Could not connect to the API server


I know there is other post on that topic but it doesn’t help me unfortunately …
so I’m on docker on synology dsm …

install went without error :

docker run -d --name=baserow \
-p 3888:8080 \
-e BASEROW_PUBLIC_URL=https://MY.IP.AD:3888 \
-v /volume1/docker/baserow:/baserow/data \
--restart always \

but I can’t sign up I have the famous message :
Network error
Could not connect to the API server.

e[36m [BEAT_WORKER][2022-11-27 17:58:58] [2022-11-27 17:53:58,489: INFO/MainProcess] Scheduler: Sending due task baserow.core.trash.tasks.permanently_delete_marked_trash() (baserow.core.trash.tasks.permanently_delete_marked_trash) e(Be[m 
 [BACKEND][2022-11-27 17:57:01] - "GET /_health/ HTTP/1.1" 200  

so it doesn’t work I feel that the problem is around the way of connecting with the Database … I spent 1 full day on that … if someone can help me …

thanks a lot.

HI @christophe , would you mind sharing a screenshot of your reverse proxy rules?

thanks for your answer
where am i suppose to find it ?

I’ve never installed Baserow on a Synology device before, but I was looking at this tutorial: How to Install Baserow on Your Synology NAS – Marius Hosting. At step 8 you’ll see that a reverse proxy rule is added and that a source hostname and port is provided. That hostname should be your BASEROW_PUBLIC_URL as described in that tutorial.

I think it’s because the BASROW_PUBLIC_URL is not configured correctly. What’s the exact URL it shows in your browser when you visit the signup page? The first part, before the / must be your BASEROW_PUBLIC_URL. So if it’s, the BASEROW_PUBLIC_URL must be

1 Like

ok …
here is the config …
do you think there is something wrong ?

Any idea ?
regarding the no solution situation … I will try other tool …
it is a pity but I spent 3 full days trying to install baserow … i begin to be tired … I install other tools and even if there is couple of issue … at one moment I find a solution here … i’m totally blocked.
what I’m doing is not crazy nor so exotic … just an install in docker ^^

ok after 8 days turning crazy and playing bolto with parameters I found a way to make it work :roll_eyes:

My config matches closely yours.
The only diffs seeable are

  • container port = 80 instead of 8080
  • no caddy, so no BASEROW_CADDY_ADDRESSES etc.

Hello everyone,

Firstly, I consider highly valuable Baserow as a huge potential game-changer to handle data ; congrats to all contributors.
I’m asking help as I’m struggling to settle Baserow in self-hosted on Synology NAS (DSM7.2) with docker (mostly through Portainer or Container Manager).
I’m not software’s ingeneer, just an advanced user ; I’ve read all pages over Baserow documentations, search over all posts in this forum, looked at some Youtubers how to install it, executed tutorials from “Marius hosting”… and played also bolto over settings without reaching full success, since many many days trying (near 15 days) , docker isn’t as good as a real package manager (as Yast, Pacman Winget…) so pity !

I’ve tried to have 3 containers (baserow, postgresql and redis), but if the 2 last works fine even remotely, baserow couldn’t connect to them, even by pointing the good IP address ; just crazy.
I’ve found a bug, not listed that redis was limit with “vm.overcommit” and I created a daily script to fix it. For somaxcon (fixed to 128 by Synology system), i didn’t succeed to make it permanent, but it seems not blocking. As this “separate” configuration crash due to postgresql not reachable by baserow, i gave up on this point.

I try to settle through docker-compose the ‘all in one’ baserow, but when i go to sign up page easily, I’m stuck with “API can’t connect”. I’ve no error in logs. I didn’t find a way to create this “admin” baserow directly with docker… Maybe an idea for roadmap ?!
Remote access is not efficient (as it points below) even if I followed the tutorial of Marius hosting on reverse proxy, and all kinds of posts…
Ports 80 & 443 can’t be used on Synology as they are used by another application (Synology use an internal Postgresql by the way).

Here is my docker file, the simpliest used now:
version: “3.9”
container_name: baserow
image: baserow/baserow:1.19.1
DATABASE_USER: baserow_user
DATABASE_NAME: db_baserow
- “8084:80”
- “8085:443”
- /volume1/frocker/baserow/data:/baserow/data:rw

THanks by advance

Hello @William,

Have you seen this tutorial on how to install Baserow on Synology NAS: How to Install Baserow on Your Synology NAS – Marius Hosting?

Let me also try to tag @christophe and @o314. Christophe, Olivier, do you have any ideas on how to help William here, please?

Hello @olgatrykush,

Of course I tryed Marius tutorial and I found some worries with redis (somaxconn and vm.overcommit), and of course with API.


Hey @William, sorry I missed these details in your post. Unfortunately, we don’t have Marius here in our community, but I found the Synology NAS Discord Community: SYNOLOGY. We can also try asking for help there. :slightly_smiling_face:

Hi @olgatrykush, no worries :grinning: I hire some help at the end of the month, I will let you know what I will discover about this blocking step. Every blessings

Hi @olgatrykush, I found a first worry that relates on the opening of ports about “BASEROW_PUBLIC_URL”, more specifically the reverse proxy of Synology needed that ports shall be opened on local network with router but also with IP provider (which connexion shall have a public IP address full stack, dynamic or fixed).
Now I have another issues with permissions that block some features of baserow (health status, models), even if installation is “root” granted… My ingeneer works on it ; i will come back with more details.

Thank you for the update, @William. Your experience will be helpful for future readers who face a similar problem. We appreciate it a lot. :raised_hands:

Hi @olgatrykush, we are progressing slowly.

I’ve got a message of error about Health_status of baserow, and also I was able to create a new database but no new table (from original dataset or a newly created one)… that was linked to a customized folder for “docker”. Moving my folder to “docker” folder solved this bug.

I still have a worry as “templates” aren’t shown, and there is no error’s message… I’m still searching the root cause for this, but it seems related to access’ rights and permissions…

Hoping to come back soon with solutions

Hi again @olgatrykush,

I think I need help, there is a mess about permissions. I have a very regular stack (close to what Marius Hosting has done), with a defined user (root-admin user) ; all my folders have wide permissions (everyone has full control), and if redis and postgresql works pretty well on it, baserow won’t work fully with :
chown: changing ownership of ‘/baserow/data/redis’: Operation not permitted (even if redis configuration is pointing to /baserow/redis)

How can this be fixed ?