Table access broken after filter configuration

One of our users tried to set up a new filter, and somehow managed to break access to the table. Everybody now just gets the error " View not found. The page you are looking for has not been found. This might be because URL is incorrect or that you don’t have permission to view this page."
The trashcan doesn’t have anything in it which I could restore. The data itself is still there, I can use the CSV export, as well as API access from N8N or other tools to get it out. The table also can be duplicated, but accessing the duplicate results in the same error.
I have a system backup from last night which I can restore (shouldn’t have many changes/data loss from the older version), so it’s not a big problem.
Anyway, I was wondering if there’s any way to recover this without a complete DB restore …

1 Like

It depends a little bit on how technical you or somebody in your team is.

If it is your own instance and you have somebody technical, you could go into the database_viewfilter table and delete the filter that caused the issue initially.

Be careful since I am not 100% sure what the implications of deleting an entry in that table are, I can imagine that it’s an okay operation but if it does end up destroying even more, make sure that you can undo the deletion.

Other than that, are you able to share some more details about the filter that broke the table? This sounds like a bug we should have a look at in general.

I just encountered the same problem.

I am exploring baserow using the free plan and am using to host my database.

Last night I set up several tables in the database and entered a number of records in each table. This morning I was going to add some more records but one of the tables is not accessible. I get the same error as mentioned in the first post. As the first post mentions, I can also export the table to CSV, but can not seem to access it from my dashboard. I tried logging out and logging back in, but still can not access.