Unable to move field columns

I have usually been able to adjust the position of my columns (fields) in the standard Baserow editor, but in at least one of my tables, I cannot move the columns.

I get this error in the top right corner:

Action not completed.
The action couldn’t be completed because an unknown error has occurred.

Hey @bgschust,

I have not seen that before, do you have a filter set or anything?

Is it self hosted or a baserow.io instance?

There are no filters set, but there are several formula fields. This is a cloud baserow.io instance.

I’ve encountered this error a few times (also hosted version), but I’ve not been able to determine what causes it.

A couple of questions for you:

  1. Is this happening on any other tables within the same database?
  2. If you clone the table that the error is happening on, does it also happen on the cloned table?
  3. If you create a new table within the same database and rebuild the fields, does it allow you to move them?
  4. How are you moving the fields—via the “Hide Fields” button at the top of the UI, or manually by dragging and dropping them in the database itself?

Hi Hiram,

I was just dragging and dropping columns in the UI. I have not had a chance to experiment with all the other possibilities, but it looks like there’s something wrong with the UX when there are formulas present.

It’s possible. But I’ve yet to pin down what it could be, so it’d be awesome if you messed around with some of my suggestions to see if we could eliminate a couple of possibilities.

You know what they say… “if the bug isn’t consistently reproducible, it doesn’t exist,” so it’d be great to figure out how to consistently reproduce it, because I’ve also encountered it a few times but haven’t been able to decipher it (yet). :hammer_and_wrench:

  1. I have not seen this happen with other tables in the same database.
  2. I got the same error when I tried to duplicate the table, so I couldn’t replicate the issue.
  3. I haven’t had time to try re-building it from scratch, but I can tell you that one of my formulas is “sum(lookup(‘Basket-Items’,‘Basket Quantity’))” and several others have a similar structure.
  4. I am not able to drag and drop columns in the main table interface or via the Hide Fields button.

I suppose the issue is technically replicated, as duplicating the table resulted in the same exact error in the new table, correct?

Since this is a lookup, do you notice anything odd about the table you’re looking up from?

The error message is the same, but the new table could not be created upon attempting to duplicate the old one, so I could not check if the bug was replicated.

I didn’t notice anything odd about the table I’m looking up from.

Hey @bgschust, I’ve looked into your problem, and tried to replicate it. The latter is quite difficult, but I think I know what the problem is how to fix it for you. A table can have multiple views and fields. Every grid view has an entry in something that’s called a “grid view field option”. Every view and field combination has one, and it contains information like the order, width, visible, etc. For some reason, one of the “grid view field options” still exists even though the field doesn’t anymore. Therefore, the changing of the field order doesn’t work anymore.

Would you mind trying deleting your existing view and creating a new one? That will probably resolve your problem because the “grid view field options” will be recreated for that view.

I think it’s caused by creating a “Link to table” field and then removing, undoing, redoing or storing it, but I don’t have the exact steps on how to reproduce this yet.

1 Like

Yes, a new grid view fixed the problem. Thank you!

I’m thinking of working with straight JSON in the web app to speed it up and then saving in Baserow for admin access for support.