Upgrade BaseRow in docker to 1.15.1/ doc issue

just for training, I was following the page Install with Docker // Baserow
In feb 23, I installed a v1.14 docker as follows :

sudo docker run \
  -d \
  --name baserow \
  -e BASEROW_PUBLIC_URL=http://localhost \
  -v baserow_data:/baserow/data \
  -p 80:80 \
  -p 443:443 \
  --restart unless-stopped \

Now I want to upgrade it to last version 1.15.1
I follow the steps :
2/ stop : $ sudo docker stop baserow
3/ upgrade :

 $ sudo docker run   -d   --name baserow_1.15.1 \
> baserow/baserow:1.15.1

4/ does not exist in doc ! may be here is the problem
5/ follow the logs to monitor it:

$ sudo docker logs -f baserow_1.15.1

answers to me :

Please run baserow with a mounted data folder  'docker run -v  baserow_data:/baserow/data ...', otherwise your data will be lost between  runs. To disable this check set the DISABLE_VOLUME_CHECK env variable to  'yes' (docker run -e DISABLE_VOLUME_CHECK=yes ...). 

Where is the problem please ?

Are you running all your Baserow docker run commands with the volume?

yes I did exactly as written.
And in addition the answer to such command is :

$ sudo docker run -v  baserow_data:/baserow/data
"docker run" requires at least 1 argument.
See 'docker run --help'.

Usage:  docker run [OPTIONS] IMAGE [COMMAND] [ARG...]

so it is blocked

in the the page Install with Docker // Baserow
the **4/ does NOT exist, missing ** ! may be here is the problem

It doesn’t seem like step 4 is missing, it’s just a small mistake in the manual numbering. We’ll change it. Have you been able to upgrade your Baserow in the meantime? It seems like you weren’t running the full docker run command with all the arguments.

hi, so long for no progress : !
I am still blocked on the last step :
follow the logs to monitor it:

$ sudo docker logs -f baserow_1.15.1

Where is the problem please ?

I would suggest first getting familiarized with Docker before attempting to use it https://docker-curriculum.com/ .

We offer other installation platforms like Installation on Cloudron // Baserow which might be easier to install Baserow into.

I believe the step you are mis understanding is step 3 which isn’t that clear in the docs. You are expected to construct docker commands and understand how to use docker to follow this guide. Step 3 shows a partial docker command

# We haven't yet deleted the old Baserow container so you need to start this new one
# with a different name to prevent an error like:
# `response from daemon: Conflict. The container name "/baserow" is already in use by 
# container` 

docker run \
  -d \
  --name baserow_version_REPLACE_WITH_NEW_VERSION \

Please replace # YOUR STANDARD ARGS HERE with the parameters that you want to run your Baserow docker container with. Do not just copy and paste this command without filling in the standard arguments.

For example this could look like:

sudo docker stop baserow
sudo docker run \
  -d \
  --name baserow_v1152 \
  -e BASEROW_PUBLIC_URL=http://localhost \
  -v baserow_data:/baserow/data \
  -p 80:80 \
  -p 443:443 \
  --restart unless-stopped \
sudo docker logs -f baserow_v1152 
# Go to your baserow and make sure it is working with all of your data as expected once it has started
sudo docker rm baserow

But once again I want to emphasize, you should understand how to work with Docker to run Baserow using Docker, there are many great tutorials out there that can help you.

Hi, Thank you @Nigel : your are right , I was worked a lot your tutos and did a complete example of upgrade of a db and all is correct . thanks again.

But , how do you create and link a persistent data volume to BaseRow please ?

sorry I made a mistake : it runs perfect with saving data on persistent volume !
—Solved —

1 Like