Upload image without extension via URL

Please fill in the questionnaire below.

Technical Help Questionnaire

Have you read and followed the instructions?

Answer: Yes

Describe the problem

I add an image via a link without a file extension and it does not appear in the window

Describe, step by step, how to reproduce the error or problem you are encountering.

I want to copy 1 picture from Airtable. To transfer, I will get a generated link to an image like this: https://v5.airtableusercontent.com/v3/u/29/29/1716624000000/28IN9YwET-MK--PB7wvPdg/8E3okhkiZRB2ZTnDnY6OYs-A4NnRy_fO-KJ4-CAlTG5dT-1kU4sV0ZoSzh18jhor18LARb5cgJ-yp67NsLXq5i91ivcjfxtHODr6dJtLWu_e5P0ksFfEkZ3rD7kOu5pnZRF472_RLfZa_fU8KtBELw/hJhIbzOfZHje-y5cDnnGXBXSvksMI5nicZ_J9y1TKA
I’m adding this link as a file in the baserow.io test database. But when I try to view the file, I see a blank page. I tried adding this link through the API and got the same result. This file can be downloaded to your local computer and opened and the file will open normally.
This only happens with links that do not have an extension; links that have extensions work well.

Provide screenshots or include share links showing:

How many rows in total do you have in your Baserow tables?


Hello @Angelina, welcome to the Baserow community! :wave:

I’ve created an issue for your request: File field type image preview issues (#2645) · Issues · Baserow / baserow · GitLab. We are going to check this out.

1 Like

Hey @Angelina, this issue was already fixed with the 1.25 release. Could you please check if the preview works as expected for you now?

Hi, yes, everything works great! Thank you!

1 Like