View Not Found when accessing table

Hey All-

I installed baserow using docker, and everything was working great. All of a sudden, when I access my only table on it, it gives me an error, “View Not Found”.

I am the only one with access to it, and have not created any views or anything. It just started giving me that error out of blue. No matter what I do with it (restart, log-out, etc) I still get the same error.

I am running latest version of Baserow on Docker!

(see below for error message)

Any help will be greatly appreciated!

Hi @albans, I’m sorry to hear that you run into this error. Would you mind sharing the output of your Docker logs just after you tried opening the view?

So I solved this issue but I want to explain it in detail because I believe it is a BUG and it took me all day to figure it out.

Basically, I created a “Date” column in my table and was expecting a date. It wasn’t working so I visited the baserow website (Date and time fields // Baserow) which showed me that US date fields are: MMDDYYY (note the three (3) Y’s). It looked as a typo but I gave it a try: I sent my date from another application to come to baserow as a date with format MMDDYYY. It was not working so to test further, I set the column as TEXT FIELD. Then, I was getting something, but it was gibberish. So after few minutes, I tried the ISO format which is YYYYMMDD and then boom I received a new row with the correct date, so I went and now changed the column to the “Date” type while forgetting to change/remove the previous row that had the MMDDYYY date. After I made this change, I could no longer view the table no matter what. I had to manually log-in to docker, and to postgresql, and remove that row, and as soon as I did that, I was able to view the table.

Nonetheless, we are very frustrated with baserow because we did not expect for the whole table to flip out so bad just because of a bad date. Why not receive an error? Maybe wipe it out for me? Maybe do not let me change the column or something. But it allowed me to proceed and in return broke the table.

Can we fix this for the future so that it never happens to anyone else?


Hey @albans, I’m glad to hear that you were able to resolve it yourself. Thank you so much for your detailed explanation. In some rare cases, it can happen that Baserow cannot render the page because something is wrong, and that it can result in a “view not found” error. We want to offer our users the best user experience possible, and that also involves fixing bugs, especially the ones that cause the view to be in a “view not found” state.

I already looked into the scenario that you described, but I’m having some problems reproducing the bug. This is needed in order to fix it. Would you mind providing me the exact steps on how I can reproduce it? What I tried so far is:

  • Create a date field in the US date format.
  • I tried sending the value 0607019 via the API, but that made Baserow respond with this error message Date has wrong format. Use one of these formats instead: YYYY-MM-DD..
  • I also tried typing 0607019 directly in the cell, but that made the frontend convert it to 06/07/2023.

It would be useful if you can provide the exact steps you made that resulted in the view not found error. If you’ve been creating rows via the API, then the date format is always in ISO format, this is also documented in our API documentation :slight_smile: . The chosen field format is only visible in the frontend.

BTW we also fixed the MMDDYYY typo in the user documentation. This should indeed have been four times Y.

What you need to do is the following:

  1. Set the table column as text field
  2. Send via API a date in DDMMYYY format
  3. The table will accept it because the column is set to text field
  4. After you receive the value, change the whole column to “Date” type
  5. Now after few minutes or after restart i am not sure, it should give you a no view found error.

Thanks for explaining. I’ve replicated the steps you provided, but I’m unable to see it in a broken “view not found” state. Do you remember which value you’ve used specifically in the DDMMYYY format? That might help me.

Seeing the logs as they probably include the exact error message would be very useful. Additionally could you provide screenshots of this table showing all you fields and also include any formulas you might have in this table?