Webhook and local network address


I’m trying to test the webook feature with a self-hosted Baserow and a homemade listenner. Everything is on the local network.
It doesn’t work, I’m getting this error message.
“Action not completed”
I suspect there’s an issue with the DNS resolve mechanism of the baserow container.
Do you know how is the container configured to handle dns queries ?

To bypass the problem I tried to replace the URL with the IP address of the listener.

But it’s being rejected by the URL validation rule. Any good reason for that ?

Hi Nicolas, we have an open merge request to fix this exact issue and allow local addresses if you set an environment variable. It hasn’t yet been merged so I can’t promise it makes it into the next release, but it should be available soon. Specifically it will add new environment variables like BASEROW_WEBHOOKS_IP_WHITELIST to give fine grained control over which IP ranges webhooks are allowed to access (currently all local ips are blocked). Additionally there will be another env var BASEROW_WEBHOOKS_ALLOW_PRIVATE_ADDRESS which if you set to any non-empty value will completely disable all webhook security checks.

See Resolve "Allow Webhooks to access private addresses/urls" (!803) · Merge requests · Bram Wiepjes / baserow · GitLab for more details on these changes.

1 Like