Wsgi consume a lot of memory

Technical Help Questionnaire

Have you read and followed the instructions at: *READ ME FIRST* Technical Help FAQs - #2 by nigel ?

Answer: Yes

Self-Hosted Installation and Setup Questions

How have you self-hosted Baserow.

We use K8 to host our baserow instance and we use the autoscaling feature.

What are the specs of the service or server you are using to host Baserow.

We provide at least 3GB of memory and we specify a limit of 5GB.

Which version of Baserow are you using.

Version 1.18.0

Describe the problem

Describe, step by step, how to reproduce the error or problem you are encountering.

Some of the WSGI container consume more than 5GB. We also deactivated the redis cache feature for some internal reason and we get at this moment 40 wsgi pods.

Hi @mathieu ,

Have you set and increased the BASEROW_AMOUNT_OF_GUNICORN_WORKERS env var? This env var controls how many worker processes are launched inside of each WSGI container, we generally see each of these processes consuming around 100-200mb so if you’ve increased this setting then you’ll see a much higher memory usage.