Having a hard time getting n8n to work with Baserow (Both Self Hosted with Nginx proxy manager)

I am a total beginner to self-hosted world (docker ect…).

Possibly, this is just a quick fix, what is the domain used in n8n when setting up Baserow (both applications are self-hosted)? Currently, I’m just using: https://mysubdomain.mydomain.com and not getting any connection to my Baserow.

I’m using nginx proxy manager and have followed this post to get it set up, and I thought working:

Am I missing something obvious, I have looked at both the n8n and Baserow communities and tried some pretty targeted google searches with no luck.

I figured it out.

Anyone using n8n and Baserow through Nginx proxy manger, don’t use the domain name (source in nginx proxy manager) for host in the node credentials.

Use the internal domain (destination in nginx proxy manager) with the container name:

1 Like

Glad to hear you got this working now! And thanks for sharing the update, it will help future readers to escape the same issue :muscle:

1 Like

Hello rheaver,

I am newbie yet i have encounter the same as your problem.

can you share your working config?

I don’t run this setup anymore. If I recall correctly, just use the command to list docker containers. Use the docker container name and just made sure they were on the same docker network.

Noted with many thanks.

I will to figure it out.

Hey @joffcom, maybe you could help out here? :pray:

Hey @ratanainfo,

Can you share what isn’t working? I run Baserow and multiple versions of n8n behind NGINX so should be able to nudge you down the right path.

Having the same issues

@joffcom as the original posted, said connection not working

I am using http://localhost:9080 as the baserow URL in n8n. and that’s the URL I use to login to my local baserow and using the only credentials that I have

default URL was https://api.baserow.io
what is the equivalent URL for API for self hosted?

Hello olgatrykush

Thank you for your assistant.

Hello joffcom

In short, i get an ERROR cannot connect to API Server upon signup.

It seems to me that it has problem or conflict Websocket implement. Thus, may need to manually adjust. Unfortunately, I do not know how. yet i am completely new to Linux world. So I am looking forward for guidance.
Please kindly assist.

Below is my configuration, follow your instruction to rheaver.

  • For this configuration:
    1 - If i change destination to baserow (my docker name), i cannot see the baserow signup page with error Bad Gateway (my baserow docker network is different from NPM (Nginx Proxy Manager) docker network.

    2 - If i change destination to http://baserow:80, I get Internal ERROR

#here is Baserow document

#Nginx Proxy Manager

Nginx Proxy Manager Configure Screens Options

Hey @seanclt

In your case localhost is local to the machine you are running on, as baserow won’t be running on what n8n will resolve as localhost it will always fail.

Assuming a default network configuration you could try connecting to and see if that works if not you may need to configure BASEROW_EXTRA_ALLOWED_HOSTS

@ratanainfo I wouldn’t worry too much about the documented nginx settings as nginx proxy manager takes care of all of that.

For websockets you just need to enable the toggle under the details tab and you should be good to go for that.

I would remove the web frontend port from the compose file as it doesn’t look like you will need that and also remove the amount of workers and run minimal then see if that gets things working.

I will grab a screenshot of the settings I use in Portainer for Baserow later today


For Dox… pls disregard it. Thank you.

Here is my configure as submitted Websocket toggle (already enable)

Here when I try to change Destination information in Nginx Proxy Manager (Configure with Result)

Hopefully, this information can contribute to your finding.

Thank you for responding, I added -e BASEROW_EXTRA_ALLOWED_HOSTS to my docker run and they are showing up in hosts file

n8n GUI > Baserow URL Used

From my baserow Container I can curl to n8n
but locally on baserow it returns nothing for baserow URL
so makes me wonder if my URL is bad

From my n8n Container sh
I was able to ping my base by hostname or IP and both works

from my n8n server I can connect to my free cloud baserow instance using the default URLs

but for my self hosted in docker I am using the following or various variation of it. I even tried with post 80

so it makes me wonder if my URL itself is bad and need some separate api URL

please correct me if I am just over thinking and when using self hosted both login URL and api URL are same